Hey, this release comes with some rework on the source code in order to make it "repository friendly" for those that want to make a repository package of it.

The Runescape player Ker Laeda have been so nice(and patient) to help me test the client through a repository and to come with input to necessary changes.
You can find his AUR package for Arch Linux at https://aur.archlinux.org/packages.php?ID=59362

If you are interested in making a package of the client this is what you need to know:
  • The user needs the minimum dependencies (p7zip-full, wget, xterm, perl and a java runtime like openjdk6 or above)
  • The optional dependencies are(ubuntu package names used): wine, pulseaudio-utils, alsa-oss
  • The client can be run from anywhere the user have write access to! However for system installs please put/dump the client folder to /opt
    and then symlink /opt/runescape/runescape and /opt/runescape/update-runescape-client to /usr/bin
    You need to make the .desktop files self, the install-desktop-icons script is designed for users without admin permissions!
  • Updating the scripts when installed inside /opt can only be done by running /opt/runescape/update-scripts as root(by using su or sudo)
    This is because it is actually the package maintainers responsibility to update the package(update-scripts can be used as an override though in case of slow maintainers :P ).
  • When installed to /opt the client will use ~/.config/runescape as the client directory where settings.conf, runescape.prm and jagexappletviewer.jar will be located.
  • If you do not want to have compability mode support (run client through wine) then you can safely remove the win32 folder!
  • If you do not want support for the user to have his/her own local user client then you can safely remove "install-desktop-icons" and the templates folder.

Here is the changelog:
#### Version 3.1 ####
* Prepared the client for distribution through repositories
 (make it aware of being run from read only locations)
 Please note that IF you are doing to make a repository for this client.
 It should be installed to /opt and then 
 /opt/runescape/runescape and /opt/runescape/update-runescape-client
 should be symlinked to /usr/bin
 Images from the clients share folder should then be symlinked to
 /usr/share/pixmaps or /usr/share/icons
 
* update-runescape-client will not give the option to update scripts
 when installed on /opt, in order to update the scripts you have 2 options
 1. copy the runescape folder from /opt and into a location where your user
    have write permissions by default.
 2. or you can run /opt/runescape/update-scripts as root (not recommended!)
 
* If the client is installed to /opt it will use ~/.config/runescape
 as the client folder, meaning you can still update jagexappletviewer.jar
 from jagex without waiting for the package maintainer!
 
* Improved the unix_findlibrarypath function (BIG THANKS TO Jmb71 FOR THE NEW REGEX!)

* AUR package will be released in the very near future (BIG THANKS TO Ker Laeda FOR THAT!)
 as i do not have Arc Linux, Ker Laeda have helped me a lot with the testing and preparations
 for the client to be distributed from a repository
 
* Documentation.txt will be discontinued and the script themselves will
 contain the documentation in the comments instead 
 (however the file will still exist just to mention the sourcefiles are the documentation themselves)

#### Version 3.0 ####
* Thanks to Paul who reported to me that the client would not work
 if preferredjava was set to default-java and the java executable in
 $PATH was a script(or symlinked script) instead of a symlinked binary
 this would cause ldd to fail on what was supposed to be the binary and
 make the OpenGL fix not work or make the client fail to launch alltogether.
 
 A workaround for this have been made for systems that are affected (namely gentoo and sabayon)
 in which a message will be displayed and show the user how to set the client
 to use a custom java binary, this will solve this issue on these affected systems.
 This message will ONLY be triggered if preferredjava is not set or is set to default-java!
  * Updated settings.conf.example with a custom java path example :)
 


Comments

Ker
18/05/2012 17:43

Arc -> Arch
;)

18/05/2012 17:49

corrected ;)

jmb71
25/05/2012 22:26

Hi, just wrote a message to you in the Runescape "Community/Linux" forum. Leaving you a quick note so that you know how to find me ;)


Cheers,

25/05/2012 22:37

i just read it ;)

sylus
11/06/2012 10:25

I can't seem to get it to work. Old client kept crashing, I updated it and it can't find java ;/

11/06/2012 12:17

run the command
sudo find / -name "libjli.so" | sed "s/\\/lib\\/\\(i386\\|amd64\\\/jli\\/libjli.so/\\/bin\\/java/g"

and add one of the java binaries as the preferredjava inside the settings.conf

if the client is installed from aur or ppa then add
preferredjava=/path/to/java/binary
to ~/.config/runescape/share/settings.conf

if the client is installed through wget(tar.gz package) then add
preferredjava=/path/to/java/binary
to ~/runescape/share/settings.conf

an example of the variable is
preferredjava=/usr/lib/jvm/java-6-openjdk/jre/bin/java

sylus
11/06/2012 21:04

I tried that, command won't work with my shell, and the java binary I have given it won't work. OpenJDK6. It worked just fine, I'll update java when I get home from work later, I need to add a file to /usr/ports/distfiles. I'm using FreeBSD 8.2

sylus
11/06/2012 21:07

To be completely fair, I used the older client for ages. Last night it kept crashing when I would click to enter the game from the lobby, it would close. I thought whatever It's due to update anyway. So I updated from the windows client and I upgraded all of the scripts. It's telling me java won't work. I pointed it to my openjdk binary with no luck.

12/06/2012 05:50

I suspect it might have to do with my OpenGL fix.
could you run the runescape script through the terminal and tell me the output? (all of it)
use pastebin so its readable for me :)

Sylus
12/06/2012 12:00

Sure! Sorry to be a bother, java is NOT my thing. I got off stupid late tonight, I'm just adding a eula package to */distfiles/ for OpenJDK6 port. Then I'll add the new work path to the config and post back.

Here is the pastbin you requested: http://paste2.org/p/2051321

sylus
12/06/2012 12:06

Actually.. The oracle doesn't have the file I need, I'll have to update my ports directory and try again in the morning. I apologize in advance, and for previous delays. Thank you for your time.

12/06/2012 14:08

no problem, take the time you need.
also i see the issue, you need to download the jagexappletviewer.jar
only Jagex is allowed to distribute that file and i had to remove it.
you should choose 1 or 2 at the
Enter the number for your choice:

1 = fetch the file from the windows client (works on all versions of 7z)
2 = fetch the file from the mac client (works on the newest versions of 7z, however the mac client is smaller)

sylus
13/06/2012 21:04

updated java and gave the config the new work path, and I installed from windows client to save time inupdating p7zip port.

Not sure where the change was made, I did both. It works as intended now thank you very much for your advice and timely response.

-sylus

14/06/2012 06:27

The jar file got removed in version 2.4 and up as me and Mod Mozza investigated if it was ok of me having it in the archive.
The legal team recommended me to not have it in the archive as it could cause trouble for Jagex if it was freely available to those countries/locations that they are not allowed to distribute the client to (as my client is kinda linked to their website through the forum and wiki).

Awesome that it is working for you now :D
I love that i made the script write debug output to STDOUT when its run from the terminal shell :3 saves me and the user tons of debugging time most of the time :P


Comments are closed.